Aurora Store anonymous login system is offline

Aurora Store’s anonymous login system is no longer working. Apparently the devs have disabled the back end due to increased bans from Google. They hope to revive the feature, but until they do, it will not work. I think the Aurora Store recommendation on Privacy Guides should be updated in light of this.
Apparently the devs communicated the news via their Telegram channel. Here’s the most recent update copied from a copy posted on the GrapheneOS forum:

Hey all, Bit unfortunate but Aurora Accounts are aggressively block by Google, which makes sense as we are growing in numbers. Yayy!!

However we have to take down Dispenser (Anonymous Login Provider) in order safeguard our account.

We’re going to take a step back & figure out smarter way to do things.

Will bounce back soon!

Thanks :heart:


Thank you for the heads-up, I’ve been wondering what’s up with the service recently. I hope the team got it figured out soon, i’m attached to the service. :smile:


Is it better to use the play store or Aurora with your Google account?

1 Like

if you have google play services disabled → aurora store

if you have google play services enabled, theres literally no difference in terms of privacy


Well, actually since using aurora store is against Google’s terms of service and the account could be banned, so there’s a difference.
You could always log in with a throw away account but I would simply use Google play, it’s safer.

1 Like

I thought it was me…

Somehow, you can still get updates if you can source a proper apk.

Recently tested this with Brave Browser. I got the apk from the latest release on GitHub and somehow Aurora was still able to update it regularly.

1 Like

Tested it again and Aurora doesnt seem to start fully.

It may be time to move on, to Obtanium?

Does it? On my device running GrapheneOS without the Sandboxed Play Services and an throwaway Google account on Aurora Store on version 4.2.1 from F-Droid, I still can use the app normaly, like searching, installing and updating apps, without problems. Or do you mean it with the Anonymous Login option?

The problem is with the Anonymous Login, as Google seems to be limiting/blocking all the Aurora Store’s accounts.

Oh ok, thanks for the clarification!

1 Like

This happens all the time. I am surprised you didn’t notice before. Just once a while it’s completely down.

I only use Aurora to monitor updates as its more quicky than Google Play strangely and install one app that Google Play thinks is not compatible. But i agree with what others said. If you use play services there isn’t much reason to use it.


Google is now banning any accounts that were used to login to Aurora Store (Specially if they’re new accounts).


It seems you are right. It may be more problematic this time.

1 Like

It works again on my device, after I updated the app.

Seems like they fixed the issue, atleast for now.


Same here actually

I can’t even install the app now :unamused:… Tried previous versions too !

I heard that they announced it was fixed on Telegram, but since I don’t have Telegram I didn’t read the actual announcement. I’ve also heard that people are still having various issues (w/ search etc.) with the anonymous accounts:

You probably installed aurora store outside fdroid so when you try to update the signature mismatch. Uninstall and reinstall

1 Like

I don’t have aurora store installed right now.

That’s weird, not even in another user profile?