Opinions on Windscribe VPN?

i can’t see twitter comment chains since i don’t have a account. and nitter is now dead. if you could take a screenshot of the thread that would be very helpful

1 Like

Seems to have started with this weirdo who is hell-bent on defending censorship and government overreach: https://twitter.com/PhilippeDelteil

When Windcribe app is launched there are various domain activities like api.984bd7c214ff9239b88a0fcf1ce64690f7c53acf.com or checkip.984bd7c214ff9239b88a0fcf1ce64690f7c53acf.com and even api.block-only-if-you-have-a-small-pee-pee.io is it OK naming?

I think these apis are used to authenticate you login? Because if they set the api to their windscribe.com domain, it will be probably be blocked as many ISPs block VPNs websites in restricted countries.

1 Like

Their Double Hop implementation is really weird, it is traditional VPN + different VPN extension server location, unlike Mullvad VPN which is built-in their app.

It is wild how far Windscribe has come. Eight years ago they seemed like the typical bottom of the barrel VPN who was selling super cheap lifetime Pro memberships (I think they still honor these, I will find out in 2026), I think my voucher was around $30 if I remember correctly. Now they may end being one of the top four or five privacy respecting VPNs out there.

2 Likes

They seem to be pretty competitive when it comes to price. I was using their ‘build-a-plan’ tier for a while for $3 a month as it was all I needed. I took them up on their recent birthday offering ($29 a year for Pro). They seem to have deals fairly often though.
Stack Social have a 3 year Pro subscription for $89 at the moment.

I’m a bit annoyed that you need to pay extra for a static IP if you want port forwarding. Unless I’m misunderstand something.

They’re used to grab the configs, when you login things like api.windscribe.com are blocked, obviously though certain regimes block that and all public DoH providers. It would seem likely Windscribe are registering temporary domains not tied to windscribe.com

Maybe with the last one having a bit of fun at the censor’s expense (seeing as they are the ones seeing that when they monitor internet traffic in their countries).

2 Likes

Well said !

Any other Fedora + Windscribe users here? (or Linux more broadly)

I subscribed to Windscribe recently and I’m encountering a number of frustrations.

One of the weirdest issues I’m experiencing is that when Windscribe’s desktop app is connected, I can’t open Firefox or various other applications, or if it does open, it might take 1-2 minutes to launch (compared to <3 seconds normally), Disconnecting and then reconnecting (after launching the browser) solves the problem. But it is extremely frustrating. So far the Windscribe Linux experience feels like a big step down, from Mullvad, but it is too early for me to judge with confidence. Has anyone else experienced an issue similar to this?

Take this with a major grain of salt as I do not use Windscribe on Linux

but this sounds very familiar (almost the exact same symptoms) to issues I have experienced with VPNs in the past. Have you tried lowering the MTU (no clue if Windscribe on Linux offers this option) value? Setting the MTU to 1280 for me in similair situations fixed this issue for me.

I use the Windscribe client on Fedora and can’t say I’ve had the same issue, but I do use other providers with it instead of using Windscribe’s servers.

Have you tried contacting them about it?

I am in the process of collecting relevant info and writing up a bug report right now. Its a bit of an odd problem to try to describe
I’m also going to give @Parish2555 's recommendation a try, see if that might help.

1 Like