Aurora store 4.2.0, but no apk?

I’ve been using the “obtainium” app on my phone for a while to manage open source software and i got an error saying yesterday saying there was no apk available for aurora store. I went to its gitlab repo and found out that there was a 4.2.0 release yesterday, but no apk available. Wut? Thoughts?

I have highlighted the 4.2.0 release here:

Give it a few days. F-droid is slow to build apps, but now that a new release ha been tagged, it should get built and released there automatically. As for builds hosted on gitlab and, I don’t know how much of the process is automated, but it should presumably be ready within a week.

gitlab releases get released before f-droid as far as i know… it’s usually the way it works with foss (gitlab, github,etc) … also, i’ve completely replaced f-droid with obtainium due to security issues with f-droid… its super awesome! give it a try :wink:

the obtainium repo for those who are interested:

The point of the post is… it has a new release with no apk… even directly from source… which is weird… f-droid is always super late. f-droid still has newpipe 0.25.0 whereas 0.25.1 has been released on april 3rd on the official repo. (it says 0.25.0 version on the newpipe page on

Why would they release 4.2.0 with no apk? did they do a miskate?

Yes, I know. Wait a few days. I’m not an expert, but my understanding is binaries coming a day or two after the release tag is perfectly normal for low key software. The binaries need to be built then uploaded. If the process isn’t automated, a human needs to do it. Maybe that human is sleeping right now, or maybe they just aren’t in a hurry. If there’s no activity within a few days, that will be more unusual. But 24 hours is a pretty small window for low activity foss development.

1 Like

one thing is for sure… i’m glad there’ s something coming out from aurora store! it’s been dead for a while!

The newest release apk on Gitlab is 4.1.1, so I’m not clear where you saw 4.2.0 - or if it was released on Gitlab, but then pulled? If you really want to take a new apk build for a spin you can download the nightly apk build from: I’m also looking forward to a new stable build since 4.1.1 is 1+ yr old! Thanks for the heads up!

Like i said earlier, im using obtainium. it said “there is no apk for this software” or something like that… then i went on the gitlab repo and saw THIS:

Obtainium gave me an error message because the 4.2.0 release has no apk available!!

4.2.0 source code is available to be compiled… not the apk itself.

the screenshot i took earlier, i hightlighted in blue the version 4.2.0 release… its right in your face when you go to the gitlab repo:

Discussion with the maintainer responsible for 4.2.0 here:

He is back:


thanks for the heads up!! looks like he’s back with a new helper from a calyxos dev, who happens to be the guy who released 4.2.0

I’ve been using F-Droid since going GrapheneOS. I recently tried out Obtainium as a replacement but everytime I try upgrading an app, I get an error saying it conflicts with an existing package. I then uninstalled an app and tried to install from Obtainium to get the same message. I can’t find a solution online. How did you migrate or did you start afresh with Obtainium?

You probably have the same app installed in another profile too, you need to uninstall it in every profile and than you’ll be able to reinstall from obtanium

1 Like

Try to reboot and also, enter the url manually using the releases directory

like so: https:// github .com /TeamNewPipe/NewPipe /releases (i had to use spaces to make my point)

like user1 said, put obtainium on owner and let obtainium do the updating and installing job for the other users.

Thank you both. I thought I’d removed it but found it on one of the lesser used profiles. I’ll do it one at a time as they require updating.