PriEco: New open source web search engine

Introducing PriEco: New private and eco-friendly web search engine!

PriEco ( is a result of my work to create a fully private search engine that also promotes ecological values.

Privacy Highlights:

PriEco never tracks or profiles you.
It’s open source: JojoYou/PriEco: PriEco is a new search engine powered by Google, Bing and Mojeek. It is focused on Privacy, Security and Ecology. - PriEco - with AGPL v3 or later license: PriEco/LICENCE at master - PriEco -
Minimal use of JavaScript, limited to search suggestions and a clear button.
You have the option to disable JavaScript entirely in the settings.

Security Features:

Enable the “Hide query” setting to prevent searches from appearing in your browsing history.
Hashed IP addresses are stored temporarily for attack prevention and are deleted automatically after one hour, ensuring your real IP address is not stored.

Index Providers:

PriEco uses Google for web results and Bing for images.
Additionally, I’m developing my own index, which you can explore here: or at the bottom of the page of search results.


PriEco is hosted on servers powered by wind energy.
PriEcos crawler, software responsible for finding websites for PriEco’s index, operates on solar energy.
In the future, I plan to allocate a portion of PriEcos profit to charitable activities.

Thanks for the project. Wanted to checkout but the website js returning “Error 500”

1 Like

Hello, Neo.

Thank you for the feedback. I have never tried Vivaldi before and wasn’t aware of this issue.

Nonetheless, as soon as I woke up I debugged this error and fixed it. You should be able to try it now.

1 Like

I like the design! Beautiful ! But you should consider using your own adserver in the future.

1 Like

Thank you!

Sure, I will build my ad server, but for now PriEco is too small to attract advertisers.

Right now there are a-ads ads, they are very privacy-friendly, so I decided to give them a try.


How can I remove this banner ?

It needed to be manually turned on in settings.

Just go to settings and turn off these

“Show time” setting turned on is your problem.

Then it needs to be saved at the top of the settings

1 Like